CollectorRegistrationManager - Service not available

Comments

3 comments

  • Avatar
    Kevin Sumo

    Hi Ronnie,

    A ping check actually wont work to the service. We block ICMP echo requests for security reasons.  This said your test via curl is valid and we see the proper response coming back from the service, so connectivity should be OK.

    Looking on the back end we see the Collector currently looks like its showing as "up" are you still seeing it marked as "down?" In some rare cases its possible the status check just did not go through, and the offline status got cached. Typically this will resolve on its own within about 15-30 minutes.

     

     

    0
    Comment actions Permalink
  • Avatar
    Ronnie Koch

    Hi Kevin,

    I had a fairly lengthy network outage (4h 14m according to my dashboard :) and I was hoping the collector would recover by it self which it did not as it was trying to ping to verify connectivity (firewall logs to prove it as I initially blocked outgoing ICMP).

    I eventually after 3 hours gave up and restarted the collector but if Sumo Logic blocks ICMP and your collector uses it maybe a fix is required :)

    Regards

     

     

    Ronnie

    0
    Comment actions Permalink
  • Avatar
    Ronnie Koch

    Hi Kevin,

    On further investigation only found my cli pings in the firewall logs. I have no idea what the collector was trying when "Pinging sumo service...." except it was unsuccessful.

    Anyway my problem solved for now.

     

    ROnnie

     

    0
    Comment actions Permalink

Please sign in to leave a comment.