Cannot get collector to pick up new local source

Comments

1 comment

  • Avatar
    Kevin Keech

    Hi Peter,

    If your Collector was not initially installed with the syncSources property set it would have been installed in UI management mode. In order to switch a Collector to start using the JSON file for management you'll need to perform the following steps.

    1.) Within the Collector Management pages of the Sumo Logic UI select to edit the Collector. Under the "Advanced" section of the configuration, you'll need to select the option for "Local Configuration File" under the Collector Management options. (alternatively, you can set this with the Collector Management API)
    2.) Update your user.properties file on the Collector to add the syncSources parameter, along with the path to your JSON file. 
    3.) Restart the Collector to apply the update. 

    As long as your JSON file is valid you should start seeing your updates apply immediately. An example of the file format for sync mode can be found in the following help documentation

Please sign in to leave a comment.